foone Profile picture
16 Oct, 35 tweets, 7 min read
SO remember I complained that Pizza Hut implemented a car-description system but limited it to 20 characters?
Well, today I'm getting Pantera Bread, and they have a similar field. But how many letters does it max out at?
150!
but also 200.

what.
gonna tell them I drive a
ford______________________________________________________________________________________________________________________________________________________________________________________________escape
nope see, they have JS limiting it to 150 characters, but the HTML max-limit is 200, so I'm able to enter that long name, they just won't accept it.
I couldn't enter a longer name (without hacking, of course)
importantly there's a non-equivalence here between this 150/200 entry field and the one on pizza hut's site
pizza hut only needed you to describe the make and model, and they had a separate field for color.
pantera makes you jam it all in one big field
also I hate their bagel allocation system
basically you first decide how many bagels you want (6 or 13) and then it makes you select numbers of bagels that add up to that many, while yelling at you to choose more or less
surely there's some better UI that could be used here.
like sliders or an interactive pie chart
to manage your bagel allocations
there's also the weirdness where you don't just specify how many bagels you want, you have to pick which bagel TYPES you want, then how many of each.
if you're sticking with this method, why not just have + and - signs on all of them, and assume 0 means "no bagels"?
it's basically allocating points to your character in an RPG

just that character is a bagel order
anyway the correct method is to let you select which bagels you want and then give you one of these skill-triangle things
you know how there's that whole "flash of unstyled content" problem in HTML design?
I think I got a relative of that, flash of untranslated content.
check out how everything has un-names, and has lots of caps and underscores
then two frames later, bam. nice names.
pantera bread: you should hire me to fix your website.
your bagel ordering experience is suboptimal

(and also paypal doesn't work at all)
also your inventory said you had brioche rolls (I ordered a lot of them, did you see?)
but like 45 seconds after ordering your baker had to call me to say you don't have any of them
IF YOU ARE GOING TO HAVE ONLINE ORDERING, YOU NEED TO TRACK YOU INVENTORY
fun fact: they actually ran out of two things I ordered but only called about one of them
the other one was bagels, so they just handed me my order of bagels and was like "we ran out of the cinnamon ones so we gave you more plain ones"
I also made the mistake of trying to use the mcdonalds app to pre-order the food my roommate wanted and good lord is that a mess
so it lets you select a restaurant, then shows you the menu, then when you click on your first item it's like WHOOPS GOTTA REGISTER!
so I put in my name and email and it demands a password.
they blocked paste in the password field so I can't use my password manager
ok whatever registered. it has to email me, which it tells me and then gives me an option to open my mail app.
the wrong one, because why would they respect my email intents?
so I go there, activate, get the fun popup of "do you want to open this URL in BROWSER or MCDONALDS?"
I go to mcdonalds, it says I'm activated, then makes me sign in again. Fun.
I enter my email (it's on autofill, so that's easy), my password, and NOPE!
see it turns out my autofilling email looks like this:
Foobar@web.site

it's got a capital letter in it, for god knows what reason.

I registered with the capital letter, and I tried to log in with the capital letter... and failed.
it turns out mcdonalds normalizes their accounts database to be all lowercase, including when you register a new account.

however they do not normalize LOGINS to be all lowercase... and it's case sensitive.
so I registered with Foobar@email.site but I can't login with that same email string, it has to be "foobar@email.site", despite the fact that EMAILS ARE NOT CASE SENSITIVE
OK I log in. it selects a mcdonalds farther away than the one I'm nearby, but whatever. I switch to the nearby one, and select my first item. I tab-switch over to discord to see what else my roommate wanted, and when I switch back... the mcdonalds app is non-responsive.
all the buttons do nothing, the back button does nothing, it's just locked up.
OK, I kill it from the task manager, go back into mcdonalds, and thankfully it remembered my login.
So my cart is empty now and it's on the far-away mcdonalds. Whatever, I fix it and start ordering
after adding the first couple items, it crashes this time.
not a lockup, just a crash. mcdonalds app just goes away between adding item 4 and 5.
I launch it YET AGAIN, select my nearby mcdonalds again, select my first 5 items, then I can't find the 6th one. It's not on the list.
it doesn't have search... but actually it does. You can search within a category, but not the global menu.
or menus, I should say.
it turns out there's three separate menus, and you can select which one you want. the item I wanted is on the breakfast menu, not the lunch menu. OK, I select it there, and... it won't let me add it? because it's not breakfast.
whatever. I'm about to give up and just use the drive-through when I notice something odd: the cart is now showing 9 items
so it turns out it didn't keep my cart from my first order to my second order, but it DID keep it from my first order to my third order.
so now it thinks I want 8 sandwiches and a coffee
I start deleting the items out of the cart when it makes it through 3 of them, pops up an advert, and when I close the advert, crashes again.
so I go to the drive through and order my items, including the one off the FORBIDDEN BREAKFAST MENU, and it goes through just fine.
You can order things (at least this one thing) off the breakfast menu at 2:30 PM, it's just that the app will not let you.
the final fun aspect is that I discovered when logging in again that the login screen DOES let you auto-fill passwords, unlike the registration screen.

Unfortunately my password manager was trying to auto-fill passwords for facebook, but you can't win them all.
or, if you're mcdonalds .app, any of them, apparently.
btw pantera didn't just refund my purchase to my credit card or anything, they instead gave me a cookie bag with dollars in it

• • •

Missing some Tweet in this thread? You can try to force a refresh
 

Keep Current with foone

foone Profile picture

Stay in touch and get notified when new unrolls are available from this author!

Read all threads

This Thread may be Removed Anytime!

PDF

Twitter may remove this content at anytime! Save it as PDF for later use!

Try unrolling a thread yourself!

how to unroll video
  1. Follow @ThreadReaderApp to mention us!

  2. From a Twitter thread mention us with a keyword "unroll"
@threadreaderapp unroll

Practice here first or read more on our help page!

More from @Foone

18 Oct
look I may be biased as someone who has historically done a lot of webscraping (I calculated at one time that I was downloading around 4 gigabytes of JUST HTML every day), but...
I think we should have both the death penalty and a special layer of hell for programmers who build sites that return 404/403s/etc as 200.

with summary execution if they do it with HTML.
you have no idea how many times I've had to write code to parse HTML to find out if I got a 404 or not, because sometimes the only way to tell is to see if there's a <div class="message">File Not Found</div> in 40k of tag soup
Read 103 tweets
18 Oct
Does anyone else vaguely miss that period around 2005 when half the new music you heard was from strange flash animations, because no one had yet worked out a way to auto-detect that particular bit of copyright infringement?
I'm listening to a Dutch fraternity cover Country Roads in a eurodance style and it's all the fault of some 4chan animation from the bush administration
Read 5 tweets
17 Oct
I once again am listening to an old game grumps let's play and they're talking about astroglide for some reason and Arin mentions it's good because it's water based, not silicon-based.
I think he means silicone.
silicon-based lubricants have historically failed in the market because it turns out sand isn't a good lubricant
maybe it's silicon-based like how silicon-based life is an alternative suggested form of live compared to our carbon-based.
Read 8 tweets
16 Oct
Another random yard sale nearby seems to be at some kind of recording studio.
Look at this pile of... mixers? processors? I don't know what this is
more of them, extra blurry this time
even more, with a little less blur
Read 115 tweets
16 Oct
every time someone mentions blaseball I'm disappointed it has nothing to do with this image.
I'm gonna have to make my own fantasy baseball league, aren't I?
OK, the story behind this image:
The game is MLBPA Baseball aka Fighting Baseball, specifically the SNES version.
So MLBPA is the Major League Baseball Players Association, so they were allowed to use all the players for the baseball sim, but they couldn't use the teams.
Read 17 tweets
15 Oct
I saw the news that Star Trek: Discovery is coming back this week and I was like "Wow, didn't S1 of Lower Decks just finish?" and thought "we must be living in the golden age of Star Trek!"

then I remembered that twice during my life I've had TWO TREKS airing simultaneously
(and both of those times, one of them was DS9)
The Next Generation ran from 1987-1994, with Deep Space Nine running 1993-1999, and Voyager ran 1995-2001.
Read 52 tweets

Did Thread Reader help you today?

Support us! We are indie developers!


This site is made by just two indie developers on a laptop doing marketing, support and development! Read more about the story.

Become a Premium Member ($3/month or $30/year) and get exclusive features!

Become Premium

Too expensive? Make a small donation by buying us coffee ($5) or help with server cost ($10)

Donate via Paypal Become our Patreon

Thank you for your support!

Follow Us on Twitter!