foone Profile picture
16 Oct, 115 tweets, 29 min read
Another random yard sale nearby seems to be at some kind of recording studio.
Look at this pile of... mixers? processors? I don't know what this is
more of them, extra blurry this time
even more, with a little less blur
these are definitely audio
I wonder if that memorex box is a camcorder or a typewriter?
oh hello, what the fuck are you? Videonics made video mixers, but this looks almost like it's some kind of laserdisc thing
and maybe that's a VCR in the background? a toploader, by the look of it.
that's a lot of cassette tape players
is that TUBES I see?
It's in San Jose, tomorrow only, in the morning.
Maybe @gewt and I will check it out. There's bound to be some interesting shit there.
sfbay.craigslist.org/sby/gms/d/san-…
OK SO @gewt and I went. They've got a bunch of stuff, like laptops and such.
Some of the best stuff isn't for sale, sadly... Like this Heatkit Color Bar and Dot Generator.
or this Colour Analyser
but they had three of these rack-mounted CRTs with all these adjustments on them
And some ADAT decks. These record & play back digital audio from VHS tapes (SVHS, specifically)
A big fancy Sony display monitor. A KV-1311CR.
this one wasn't very focusy but it's a fantsy Mitsubishi SVHS VCR, with a fold-down control panel.
So, here's the thing: The place isn't just open for this today-only yard sale like they advertised.
They're a recycling place that also makes lights, but they're also selling off a lot of electronics surplus from a TV repair shop and also Excess Solutions.
yeah apparently Excess Solutions of San Jose sold them a bunch of old inventory. So they have a lot of laptops from them, for cheap.
If you're in the San Jose area, it might be worth checking out. Lots of audio tech that I have no expertise in.
It's U-Recycle at 2137 S. 10th Street, San Jose.
(Google is not very good at finding that place. it's the mini-mall sort of thing, and it's on the left side)
but I may be going back there to dig through some of the other stuff, and do some research on it.
We ended up grabbing some laptops and a Thing. I got a Compaq Armada 7770, which is a 233mhz Pentium MMX, 32mb ram, 3gb HD, built in audio and S3 Aurora video, 12.1" 800x600 display, built in 14.4kbps faxmodem.
The outside is in bad shape but it seems to just be cosmetic damage.
it's one of those fun models which have a built in AC adapter, which is nice, as those are always a bit of pain to source.
it also had a 19.2kbps faxmodem jammed in one of the PCMCIA slots, but of course the dongle is missing.

the dongle is always missing
the Thing I got was this.
It's a Videonics Video Control Unit.
I believe this is a basic titler/simple effects generator? But it's not terribly useful without the remote.
But here's why I got it.
See those ports on the back?
Serial mouse, printer, DIN-5 keyboard?
That smells like a PC to me.
This thing may just be a fancy x86 machine in a weird box.
so I'm definitely going to open it up and see how it works.

Anyway @gewt got two laptops as well, a thinkpad and a toshiba satellite I believe? But I'll let her post about 'em if she wants.
So when I power on the Compaq, it lights up, but never initializes the screen.
I yanked out the battery, hard drive, and floppy drive, and now it at least tells me this system has 98mb of RAM.
So maybe one of those is broken and was stopping it powering on?
I put the hard drive back in and now it's booting!
So probably the battery, yeah.
it's unlikely the floppy drive broke it...
And it's booted!
And this is a fresh Win98 install, definitely.
And given that it thinks the date is 12:01 am January 1st 1980, either it's a weird time machine or the CMOS battery is dead.
the install date on the windows seems to be March 2000.
Did someone really just reinstall this machine afresh and then stick it on a shelf for two decades? huh.
The 3gb drive is split up into two partitions.
Plus a SECRET non-dos 12mb partition. Hmm. Some recovery thing, maybe?
SHIT IT IS A TIME MACHINE! THERE'S A DOJ MEMO INTO CLINTON FUNDS

or maybe it's just a very very stale cache
I want to take a high quality screenshot of this but THEY DIDN'T INSTALL MS PAINT

WHAT KIND OF BULLSHIT WIN98 INSTALL IS THIS
I CAN'T EDIT AN IMAGE
fortunately (since it has no CD-ROM drive or floppy drive), it has the win98 install directory copied into C:\win98

so I can just install mspaint!
and now I have a BMP of that screenshot.
which I can easily copy off using... uh... shit.
"foone why don't you just use a USB drive"
1. it's win98. it doesn't have generic mass storage drivers, so I'd have to install the driver first, which probably doesn't exist, and also, how do I get the drive onto it?
2. no USB ports
so... options:
1. serial ports. I could null modem it off?
2. infrared port. this should work... but I don't have a reciver for my PC
3. PCMCIA cards. I could use one of those PCMCIA+CF adaptesr!
4. modem. Dial into an (internal) ISP and get on the net
5. reinstall the floppy?
reinstalling the floppy seems most on-brand for me so let's try that one
that seems to have hung the formatter.
maybe this drive is slightly broken
and bluescreen.
I've plugged this thing in for under 20 minutes and already I bluescreened it.

AHH WINDOWS 98 HOW I MISSED YOU
I'm now going with option 5b: repair the floppy drive.
It seems the top panel has been bent and may be pushing against the disk, probably keeping it from spinning
components on flex! I bet these are used to identify what device it is? since this connector isn't just a floppy drive connector, it can also be used for a CD-ROM drive.
seems to be working a bit better now
nope. can't read a:
lemme try getting into the BIOS. I tried earlier but it didn't work, so I gotta look up the manual
ahh, f10, of course.
huh, that's an interesting UI toolkit for the bios
wait what?
I selected "computer setup", it said "COMPUTER WILL NOW REBOOT", it booted, but instead of dropping me into windows 98... I'm now in what's clearly windows 3.1?!
DOES THIS LAPTOP HAVE WINDOWS 3.1 IN ROM TO RUN THE BIOS SETUP!?
Yeah, this is windows 3.1.
and it appears the system booted off a F:\ RAM drive.
weird!
I bet this is what that 12mb non-DOS partition is: a compressed windows 3.1 BIOS menu
For fun, you can drag the window off the screen. it turns out it's not maximized, just sized exactly to the window, and they didn't mark it non-movable.
And once you're in help you can TRY to print, but sadly it doesn't actually trigger the control panel here, so I can't escape.
Ahh, interesting. Instead of seeing the win98 C:, I see "Diags" as drive C:
So I bet that 12mb drive is not a compressed copy of windows 3.1 at all, it's just a regular one that gets copied into RAM to prevent you modifying it accidentally.
probably when you try to go into the bios, changes the partition type from non-dos to regular dos, sets it active, then reboots, and the startup files for it copy itself to the ram drive and launch from there.
when I quit, it'll undo that.
interestingly, before the metamenu to select setup launches, there's a moment of "Starting MS-DOS"

So either all of it is in that 12mb partition, or this also has DOS in ROM?
very weird machine, this.
anyway the floppy drive is still fuckt.
I think I'm just gonna have to yank out the hard drive and pull the BMP file off that way.
Which I probably should do anyway: it'd let me capture a copy of that weird partition and see what's inside it
Let's see if this works
Nope. No PCMCIA cards detected.
So inside the plastic case of the hard drive, there's a little metal box.
It's like those diagrams on floppy sleeves telling you not to get them near magnets or use them as a kite
Inside that is the drive itself.
It's an IBM model, 3080MB.
44-pin IDE.
so I'm putting the hard drive aside to image later, and now I'm gonna look at the Videonics VCU-1.
So on the bottom, we've got three screws, three mounting points, and a "remove only when adding expansion module" panel. Interesting.
Those mount points turn out to be long screws
And there we go! interesting. The connection between the parts turns out to be just some contacts on a bare PCB
It turns out it's just a bunch of pogo pins that pressure-fit onto the other board.
No wonder it has so many screws holding it together!
And we're in!
Surprisingly little in here. I was kinda hoping the fact it mouse/parallel/keyboard meant it was a SECRET PC, but no, this is definitely not a PC
So this PCB calls itself the "Source Add-on".
Copyright 1988.
I'm guessing these are debug pins?
It turns out the pogo pin bare PCB thing is used twice, with these REALLY LONG HEADER PINS raising it up.
Then the pogo pin thing is just double-sided.
Nothing really on the bottom
Though there is a '91 date, so this actual unit is newer than the '88 date on the PCB silkscreen
So what's powering it?
It looks like these are two Motorola MCU6805 microcontrollers. Those are 8-bit chips from the 6800 series.
So that's the bottom part. Let's open up the top part!
and it's a lot more complex in here.
So we have two of these CD74HCT22106E.
These are 8x8x1 crosspoint switches with memory control. Presumably these are used to swap between various inputs?
This is a Motorola S38FC004PG02, which is... a chip.
that's pretty much all I can tell.
It's a chip, by motorola.
Next, we have a NEC D70308L-8.
OH HEY, DO YOU KNOW WHAT THIS IS? It's an NEC V40!
The NEC V40 is one of the chips from the NEC V20 series. The NEC V20 was a pin compatible Intel 8088 clone, the chip used in the original IBM PC.
The V40 version includes some external chips on-die, like the UART, PIT, and parallel port.

So this device is x86 based!
And this over here is an NEC D4464C-12L.
It's a SRAM chip, 8 kilobytes.
Interesting that there's an unpopulated header right next to it.
Maybe more RAM would fit in here?
And over here we have a Motorola MC1378P.
This is a Color Television Composite Video Overlay Synchronizer. Basically let helps you generate some RGB video and then merge it over an NTSC or PAL signal.
And wow, that's some interesting bodging going on there.
Over here, we've got a MC34074P op-amp, and a MC144110P 6-bit digital-to-analog converter.
The linear regulators are interestingly mounted. They designed the PCB with a slit in the middle, which they routed a bit of metal up through it and mounted them to that.
I missed it at first, but near that SRAM chip there's 8 of these NEC D41256C-12s.
These are DRAMs, 32 kilobytes each.
So that's 32*8, 256 kilobytes in total.
So it looks like there's a hidden IR receiver here. This device connects up to the front, but you can't tell it's there from the front.
also I noticed that SRAM chip is REALLY TALL.
What the heck is going on with that socket?
and there's another unpopulated header here, helpfully labeled "reset"
So here's the thing: Imagine this IS an almost-PC, with some microcontrollers in the secondary box handling input, and most of the smarts in this main box. We've got CPU, RAM, video overlay stuff... what's missing?
a BIOS! where would the firmware of this thing live?
so I gotta point fingers at this thing.
Maybe this is the firmware, on a custom mask ROM?
@tomfleet pointed out why the ram chip was so tall, and I double-checked to confirm it:
That socket hides a chip! It's a DS1216 chip, which adds a battery and NVRAM controller which keeps the data on the chip active.
So this is acting more like a tiny SSD.
Pulled it out and flipped it to see if there's any interesting stuff on the other side.
Nope!
I tried plugging it in to see if it'd do anything without the keyboard connected. Nope!
The power and attention lights come on, and nothing comes out the Monitor or VCR-out ports.
I thought it might be only able to sync to another signal so I piped in some laserdisc video, but nope. nothing.
apparently the way this thing worked is that it talked to VCRs over that 3.5mm TRS jack serial protocol. So you'd set up a set of edit lists to control one VCR, then it'd play it back onto another VCR. (Apparently this was done by encoding the edit lists into the VHS tapes)
and if this site is correct, it turns out most of the software is included on a VHS TAPE SHIPPED WITH THE DEVICE.
spaco.org/vcu1faq.htm
so it sounds like they have some way to encode data into the off-screen area of a VHS tape and they use that for storing the edit lists, so they reused that tech to store the software for the machine itself!
in other words, OH MY GOD, this is an almost-PC that loads software off VHS tapes. I love it.
which makes sense. I saw this picture of VHS tapes in one of the listings and thought it was just VHS tapes explaining how to use the machine, but NOPE, they're software.
This particular auction includes the Video EditMaker add-on.
None of the ones I've seen so far have the bottom module that mine has, they're either just the top part, or with the Video EditMaker
See those two keyboards? The bottom one is the main one for the unit, and the top one is the EditMaker/TitleMaker one.
Here's an even bigger stack than mine!
in addition to the main one on top and the I/O module on the bottom, it adds S-video and aux edit control.
Mine might be fried.
Another listing shows that they tried to power it on, only to get this screen, which is clearly telling you "STICK IN THE PROGRAM TAPE, STUPID"
There's one copy on ebay which has the tape, for sure. This one:
meant to drop the link too:
ebay.com/itm/New-NOS-Vi…

at 150$ that's outside my just-wanna-find-out price range. But I'm going to keep an eye on others showing up, and then figure out a way to digitize that tape.
@Tahgtahv alerted me to one of these videos being on the internet archive.
it seems the data is encoded in the visual area! but sadly the compression murdered it.
that video is here:
archive.org/details/Videon…
a quick guess is that the encoded data is 72x24 B&W pixels, or 192 bytes a frame. (let's not worry about what interlacing means here)
and it appears the data transmission goes on for 4662 frames, so that's about 875 kilobytes.
the VCU-1 doesn't seem to have that much RAM (it's got 256kb, and it can't use all that for code, since it needs to RUN in that RAM too.
So unless that Mystery Chip is also RAM, that means the encoding has to have a lot of duplication/overhead.

• • •

Missing some Tweet in this thread? You can try to force a refresh
 

Keep Current with foone

foone Profile picture

Stay in touch and get notified when new unrolls are available from this author!

Read all threads

This Thread may be Removed Anytime!

PDF

Twitter may remove this content at anytime! Save it as PDF for later use!

Try unrolling a thread yourself!

how to unroll video
  1. Follow @ThreadReaderApp to mention us!

  2. From a Twitter thread mention us with a keyword "unroll"
@threadreaderapp unroll

Practice here first or read more on our help page!

More from @Foone

18 Oct
look I may be biased as someone who has historically done a lot of webscraping (I calculated at one time that I was downloading around 4 gigabytes of JUST HTML every day), but...
I think we should have both the death penalty and a special layer of hell for programmers who build sites that return 404/403s/etc as 200.

with summary execution if they do it with HTML.
you have no idea how many times I've had to write code to parse HTML to find out if I got a 404 or not, because sometimes the only way to tell is to see if there's a <div class="message">File Not Found</div> in 40k of tag soup
Read 103 tweets
18 Oct
Does anyone else vaguely miss that period around 2005 when half the new music you heard was from strange flash animations, because no one had yet worked out a way to auto-detect that particular bit of copyright infringement?
I'm listening to a Dutch fraternity cover Country Roads in a eurodance style and it's all the fault of some 4chan animation from the bush administration
Read 5 tweets
17 Oct
I once again am listening to an old game grumps let's play and they're talking about astroglide for some reason and Arin mentions it's good because it's water based, not silicon-based.
I think he means silicone.
silicon-based lubricants have historically failed in the market because it turns out sand isn't a good lubricant
maybe it's silicon-based like how silicon-based life is an alternative suggested form of live compared to our carbon-based.
Read 8 tweets
16 Oct
SO remember I complained that Pizza Hut implemented a car-description system but limited it to 20 characters?
Well, today I'm getting Pantera Bread, and they have a similar field. But how many letters does it max out at?
150!
but also 200.

what.
gonna tell them I drive a
ford______________________________________________________________________________________________________________________________________________________________________________________________escape
Read 35 tweets
16 Oct
every time someone mentions blaseball I'm disappointed it has nothing to do with this image.
I'm gonna have to make my own fantasy baseball league, aren't I?
OK, the story behind this image:
The game is MLBPA Baseball aka Fighting Baseball, specifically the SNES version.
So MLBPA is the Major League Baseball Players Association, so they were allowed to use all the players for the baseball sim, but they couldn't use the teams.
Read 17 tweets
15 Oct
I saw the news that Star Trek: Discovery is coming back this week and I was like "Wow, didn't S1 of Lower Decks just finish?" and thought "we must be living in the golden age of Star Trek!"

then I remembered that twice during my life I've had TWO TREKS airing simultaneously
(and both of those times, one of them was DS9)
The Next Generation ran from 1987-1994, with Deep Space Nine running 1993-1999, and Voyager ran 1995-2001.
Read 52 tweets

Did Thread Reader help you today?

Support us! We are indie developers!


This site is made by just two indie developers on a laptop doing marketing, support and development! Read more about the story.

Become a Premium Member ($3/month or $30/year) and get exclusive features!

Become Premium

Too expensive? Make a small donation by buying us coffee ($5) or help with server cost ($10)

Donate via Paypal Become our Patreon

Thank you for your support!

Follow Us on Twitter!