foone Profile picture
14 Sep, 97 tweets, 21 min read
it was suggested that I should add the Hilton Hotels Training Game to the death generator so I went and go it and it's a bit... wow.
this is the most game
PICK UP THAT CAN
why does this guy have so much idle animation for a hotel training game
which button to I press to eat dessert
god I love Chips brand Chips
HAH! SUCK IT EU COOKIE CONSENT DIRECTIVE, I'M TAKING ALL THE COOKIES
the game betrayed me
I can't push a button to get a drink.
this isn't a soda machine, so don't tell Jess yet.
I don't want to pretend with you. is there a safeword?
I need to hack this game to let me pick up and throw all items
I want to throw milk packets at his head
PC LOAD LETTER!?
BTW it's on the internet archive here, and it contains instructions on how to get it working in an emulator. It's slightly tricky, you have to use some cheats to bypass a certificate check.
archive.org/details/Hilton…
I can get into the elevator but I can't seem to get to other floors
BTW the game requires you enter a hotel code before it lets you play, but you'll never guess what the code is
oh shit, this game has character classes?
OK I picked engineer and now I can go up the elevator. time is passing. there's no mission yet. I don't know what I'm doing
I AM PREPARING TO BEGIN TO APPROACH ROOM 112
*hacker voice* I'm in.
the guest is here. he has an idle animation, of course.
another bald man
aww yeah we've got portraits. this is definitely going in the death generator
there's nothing to do in here. I can't flush the toilet. talking to the guy gets nothing.
I don't think I'm supposed to be here
my radio!
I've always dreamed of a game that let me walk around a nightmare hotel and fix overflowing toilets
and today that day is now
ok I gotta go right.
hello, not-bald-man
I can pick from three responses
I can't fuck with the thermostat, but it's already set to a nice temperature
all my gaming life I have waited for this moment
beautiful
I tried to run out of the room to take a screenshot of this random person walking down the halls, and then it asked me if I was done with the room
when I said "yes" it complained that I "touched something without permission" but all I touched was the toilet
I think I'm supposed to go in and talk to the lady, then look at the toilet, then talk to her again to ask if I can fix it, then fix it, then come back and tell her it's fixed and she can call the front desk if anything went wrong
GOTY
yeah I don't know what to do about this.
WHAT KIND OF SHIT-ASS AC UNITS DID YOU BUY? I JUST FIXED 112's!
I aint talking to that lady again. I'm just in, fix, out, done.
I'm out. You better be paying me for this, Hilton.
I don't know what this means
btw if you get in the way of a guest, they will shove you around, and then fade away to transparency.
two guests can be walking around the same area at the same time, but they don't have collision against each other, so the game just makes them walk through each other
elevators are used by guests, but they don't really USE them, they just go into them and fade away
And if you stand in the right place in the elevator, guests will materialize and then shove you out of the way.
I wonder what happens if they materialize inside me.
can I get telefragged?
Remember, Hilton Guidelines are to NEVER TELEFRAG guests!
I finally got it to "telefrag" me, but sadly it just shoves you sideways really fast.
let's get serious. who cares about power wash simulator? I've got Hilton Hotel Vacuum Simulator!
I'm a rebel, baby. I'll clean any room I want.
I was hoping to find tinder boxes, oil, or laudanum. but apparently this ISN'T an Amnesia custom story, after all
when I'm housekeeping I can select ENTER after knocking, but it just makes them mad at me, I can't barge in on people
despite this clearly annoying them and getting me Five Red Half Stars, my SALT apparently won't go down anymore from the same issue, so I can't get my hotel closed and me fired
oh my god
I burst into a room I wasn't supposed to be in, and it was vacant, but they left the TV on.
they are playing a video game... they are playing THIS video game
which button do I press to have an existential crisis about discovering the fact that my entire world is only a simulation?
I followed this woman into her hotel room (there's no way to make that not sound creepy) but she's not in there. I checked.
Did she jump out the window?
there's a little gap in the elevator door, and you can see through it that the elevator doesn't move. it teleports.
the outer door won't open. there is no escape from the Hiltonplex
I dunno why this dude is just standing in the lobby
now there's just one question:

high road or low road?
lemme flip a coin. heads. high road it is!
time to burst into a room I'm not supposed to be in and see what they're watching on TV
heh. they definitely didn't expect you to be able to read this text
good old FadEks.
they definitely thought this texture would be low res and this game would be internal only, or they wouldn't have just used brand names here
so there's two files in the data_psp\Maps folder. I'm guessing they're just the upstairs and the downstairs?
but let's swap them and see if it explodes.
no explosion, but it does break the menu. it just dumps you right into the game, playing as an engineer
ahh.
4B16F508D60FAF06 has "MainMenu" in the beginning of the file, and "57FCFB6E406B2B08" has HGI.
So I guess 4b* is the menu, and 57* is the game itself.
I'm already in, lady.
TEXTINJECTION
so the data_psp\Regions folder has 4 rgn files:
0A1582B4A4732C16.rgn: Elevator
4CC4F3A8D433EC75.rgn: Lobby_MainMenu
BF2C7BEE7FD8F181.rgn: GuestRooms
F9E570402866A380.rgn: Lobby
so what if we swap the lobby for the lobby main menu?
doesn't make any obvious difference. let's get weirder: replace lobby with the guest rooms
oh I'm an fool and I'm editing the wrong files. IGNORE ME, TRYING AGAIN
ok swapping in the main menu lobby for the regular one keeps the game from loading when you start a new game
let's try over writing the guest rooms with the lobby.
nah, seems to just break the elevator. it seems like it's going somewhere, but you go nowhere.
an interesting thing is that it loads all the levels and dialogue off a memory stick. I think they were planning on being able to customize and update this game by just swapping out the memory stick, without having to release new UMD discs
playing around with hacking levels and I just realized they have two different printers here. huh.
I tried and failed to turn the clogged toilet into a television.
There's a lot of names in the map files but I think they're item names, and there's pointers or something that set what they are, it's not using the text.
the company that made this game says they made a windows version too:
virtualheroes.com/portfolio/comm…
interestingly the PSP binary has some mentions of networking.
There's no options for that in the game that I can see, but maybe different memory stick contents could activate it.
MULTIPLAYER HILTON HOTEL SIMULATION
here's a news segment about the game!
metacharacters! {string:0} is replaced with the players first name.
thank god, it has a pipe symbol. that'll make extracting the font easier
I AM HERE TO KICK ASS AND EXTRACT FONTS AND I AM ALL OUT OF ASS
font
my eyes hurt
hmm, I think this game is doing some weird fontness. I'm getting strange things where individual letters are not aligning properly.
it's close enough for reasonable-looking example pictures, like so.
I think it might be doing some non-integer scaling for the original game, and my attempts to get the emulator to render it "cleanly" are trying to make it cleaner than it is in reality.
I do have a dump of the texture atlas, I could maybe just swap these in, and the end result will basically be the game but if the font renderer was a little better.
since I don't think I can make mine as weirdly inconsistent as the one the game actually has, the least I can do is default to making it good
man I don't know if it's this game or PPSSPP but every time I've tried to Cheat on it, it's impossible.
it's like it's re-arranging all the memory every second or two
I tried to cheat to move my player character so I could walk through walls, and failed
and then I tried to cheat for more cookies, and failed on that too
I'm currently leaving it fullscreened on my top monitor. guests walk back and forth, time moves on, I keep an eye on the cookies. very relaxing.

• • •

Missing some Tweet in this thread? You can try to force a refresh
 

Keep Current with foone

foone Profile picture

Stay in touch and get notified when new unrolls are available from this author!

Read all threads

This Thread may be Removed Anytime!

PDF

Twitter may remove this content at anytime! Save it as PDF for later use!

Try unrolling a thread yourself!

how to unroll video
  1. Follow @ThreadReaderApp to mention us!

  2. From a Twitter thread mention us with a keyword "unroll"
@threadreaderapp unroll

Practice here first or read more on our help page!

More from @Foone

14 Sep
The telephone was invented around 1876 and in 145 years since we've managed to make it able to do anything but transmit the human voice
I ordered some sandwiches earlier and got two calls about how they are out of and would I like to swap it for another ingredient? they've got and, and some.
I have no idea what is missing, off which sandwich, and what they are going to replace it with. I couldn't hear that part. I repeatedly said I couldn't hear them and asked again, but I didn't hear the responses
Read 5 tweets
14 Sep
honestly the best, perhaps only, way I've found to manage having multiple bluetooth devices and a single pair of headphones that talks to all of them?

I turn off bluetooth on all the devices I don't want to use.
like I need to get in on a work call?
bluetooth->on
KVM to my home computer: bluetooth, off.
pick up my phone: bluetooth, off (WARNING YOU MAY NOW GET THE VIRUS)
pick up my work phone: bluetooth, off.
this is slightly annoying. but it seems to be the most reliable way
Read 11 tweets
14 Sep
Sublime Text: perhaps the only program that lets you easily unlicense it, for some reason.
are you tired of having the commercial version?
do you miss the "hey register this please" nag popups?
WELL THEN YOU NEED TO DO HELP->UNLICENSE!
(the real reason you might need this feature, and why I just used it, is that if you need to upgrade your license you unlicense it first)
Read 5 tweets
14 Sep
the internet is too small.
I was trying to find an image of a line from Red Dwarf: "Don't give me that Star Trek shit, it's too early in the morning!" and I google image searched (part of it), and got this result. Why is this annoying?
this image.
You see how it's got kinda ugly weird borders on the Impact font?

Yeah that's because I didn't have photoshop at the time and was making all my memes in Inkscape.
I MADE THAT MEME.
IN, LIKE, 2006. FOR 4CHAN.
Read 4 tweets
14 Sep
You know, Star Trek TV shows went on a long hiatus between the end of Enterprise and the start of Discovery, and one thing I now realize I didn't miss during that sad period was CONSTANT GEEK ARGUMENTS ABOUT HOW MUCH STAR TREK SHOWS SUCK
I haven't started watching any of the New Trek yet but from what I've heard, I should avoid:

Discovery, because it sucks/isn't trek
Picard, because it sucks/isn't trek
And
Lower Decks, because it sucks/isn't trek
And it's not looking good for the other two or three ones on the way
Read 10 tweets
14 Sep
So for Keyboards 4.0 we're dropping all the locks. No scroll, num, or caps lock.
You want to talk in uppercase? You hold shift. You want to break your numpad? Too bad. You use Excel and think you need scroll lock? OUT!

So what 3 emojis/other unicode do we get keys for instead?
My personal vote is ❤️💾🎶
But that's mainly because emoji support for 🏳️‍⚧️ is very inconsistent. (Twitter implemented it based on a draft, I believe)
Read 37 tweets

Did Thread Reader help you today?

Support us! We are indie developers!


This site is made by just two indie developers on a laptop doing marketing, support and development! Read more about the story.

Become a Premium Member ($3/month or $30/year) and get exclusive features!

Become Premium

Too expensive? Make a small donation by buying us coffee ($5) or help with server cost ($10)

Donate via Paypal Become our Patreon

Thank you for your support!

Follow Us on Twitter!

:(